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Introduction 
 
 
 
 

This guide describes how to set up document templates for use with VPSign client runtime and 

VPSign VPad, using the Siganture wizard designer. 
 

•••• VPSign client runtime facilitates and control document routing to and from VPSign's VPad. 

 

• VPSign VPad enables end-customers to comfortably review, remark and/or securely and 

naturally, sign full-view documents presented on its display. 
 

These two modules work together to let power users easily integrate VPSign's solutions 

with existing operating space and information systems.  
 

The user guide is intended for personnel responsible for defining and setting the document 

handling procedures for desired business tasks requiring printout processes replacements for 

savings and efficiency. Signature wizard designer is a studio environment for creating signature 

boxes, extracting data fields from input documents for external use, dynamically setting input and output 

filenames and  adding powerful add on scripts for best and efficient document processing and 

integrating. 
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Overview 
 

Business paper based document processing can be easily replaced now by full efficient time 

and money saving electronic process from end-to-end, using VPad and VPSign suite. 

Integration is made short and light, using the user friendly, easy learning, Signature wizard 

designer. 

SWD interface is specially built to assist any power user to create document templates for 

VPad processing, from any source, format or system: word, pdf, tiff, legacy systems 

printouts, ERP, CRM etc. This task involves first time document capturing, document 

unique type identification,  defining different and dynamic input and output file name 

patterns for enhanced classification,  tagging desired in-file texts strings for extraction and 

external use, adding before and after session scripts, managing template files and more. 
 

. 

 
Document Templates processing 

 

Document templates are created by SWD and stored as XML files. While VPSign client engine 

process inbound document printed to it, searches for, identifies and matches the predefined 

associated template, and processes the incoming data according to the current template properties.  
 

        NOTE: Products of this stage are the VPad's input format files and additional  

             Content-extract files. 

 
 

User Exits 
 

VPSign client exposes two user exit hooks for external enhancements during processing. These 

entry points can be used to add any pre or post session proceedings for enhancing document 

handling operations during its processing, according to the desired business need and demands. 

This is achieved using the powerful industry standard LUA scripting language, a full function 

widely used programming language that excels with its rich library of free functions and code.  

For further knowledge please visit http://www.lua.org/. 
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Template Designing 
 

 
 
 

This chapter describes how to design a new VPad template. 
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Template Design 

 

 

 

Capturing a document to designer 

This section describes how to start template designing by capturing the first produced document 

into SWD workspace. 
 

Initial setup 

 
 

 
To configure the needed parameters for initially capturing a document to the Designer: 

 

1.   Right click the VPort agent icon in the system tray. Left Click "configure". 
 

 
 

 

 

2.   Choose "VPrint configuration" on the left menu tree. 
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3.   Select the desired resolution and paper type: 

  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Document Capture 
 

1. Right click VPort agent icon on the system tray:  
2.  choose "Capture next document to Designer". 
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3.   Printing any document at this state to VPSign VPad printer will start the Signature Wizard 

for the specific document in its workspace. 
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Designing a VPSign Template 

 

 

Creating Template identification 

 
 

 

Creating the template's ID, will enable VPort agent to recognize and match all future 

documents printed to it, bearing the same unique ID, for processing according to this 

template's properties. Choosing the right unique ID for each template is there for crucial. 

Template ID can be created using any string in the template content or name. 

 

 

1. To create a template ID using a string in the template's content, Click "Create mode" 

Button on the top toolbar. 
 

  
 

2. Click "Add Identification" Button on the top toolbar. 
 

   
 

3. Choose your ID string by holding left mouse button and marking a box around it. This 

sample template ID is the string: "Absence Request".   

When done, release the mouse button. 
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4. The Template ID object is created in the Document identification folder, under the 

object browser tree on the left side. 
 

 
 
 
 
 
 
 

5. Right clicking the object will pop up the following window: 
 

  
 

Choosing "Delete" will remove the object. 

Choosing "Properties" will pop up the object properties page: 
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Marking Signature Boxes 

 

Signature boxes are used to mark users required signature areas in the document. Users must 

sign each signature box before being able to approve the document and send it back to its 

originator. Signature boxes can be created with or without a signature line: 

 

 

 

1. While in "Create mode", click the "Add signature box" button. 
 

  
 

2. Choose box style (With or without a signature line ) : 
 

 
Note : this is just for convenience of use while designing the template cause on Vpad the  

            signature box always appears with signature line.  

 

 

3. Locate the planned signature area, mark a box around it by left clicking the mouse 

button while holding it, dragging the corner and releasing the button. This will 

create a dark blue box marking the signature area, bearing a serial order number. 

Creating more than one box in the same page, will add an ascending numbering to 

each box, to present its processing order. This can be changed, by reordering the 

boxes. 
 

 

  
 

 

 

 

4. To reorder signature boxes in the same page, right click "Signature boxes" on the 

object browser and click "Signature boxes order". 
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5. To reorder signature boxes in the same page, right click "Signature boxes" on the 

object browser and click "Signature boxes order". Choose the box you would like 

to reorder and use the right up and down buttons to relocate its order. Click 

"Apply" and "OK" buttons. 

  

  

  

  

  

  

  

  

  

  

  

  

  
 

  

   

Editing signature boxes while designing 

User can see the result of each/all signature box(es) while designing when working with connected Vpad. 

1. To print an example document with all defined signature boxes, open “File” menu then chose “Print To 

VPSign VPad” or alternatively click “Print To VPSign VPad” icon from upper menu pane: 

  

  

  

  

Or by using upper menu     
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2. To print only current signature box that is being edited, while in "Select mode", put mouse 

curser inside the borders of the desired signature box then right click on the mouse, a 

menu will pop up, click on “Print signature box”. 

                      
 

3. To export the signature wizard file meaning to produce a tiff file with the signture boxes 
defined inside that can be sent to vpad, open “Tools” menu then chose “Export signature file…”. 
  
  
  
  
  
  
  
  
  
  
  
  
a “Save As” dialog will open, input desired file name, click on “Save” button. 
 
 

Using template triggers 

 

Triggers are used to serve as relativity "anchors" for objects positioning and detection. This 

feature is particularly significant while processing dynamic text layout documents, where 

strings of text lining vary in position depending on previous objects length. In these cases, 

using a unique trigger might assist in identifying the actual positioning of neighboring 

objects, relatively to the known trigger. For example, if we would like to mark the employee 

number in our sample document, and we are not sure if the line containing it would always 

be on the same line, we can define its left title" "Employee Number:" as a trigger, and refer 

the actual number positioning to its trigger. 

 

 

1. While in "Create mode", click the "Add trigger" button. 
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2. Locate and mark a box around the string you would like to use as a trigger,  by left 

clicking the mouse button while holding it, dragging the corner and releasing the 

button. This will create a green box marking the trigger. 

  
 

A trigger object would be created in the triggers folder of the object browser: 

 

 
 

Right clicking the object would enable you to delete it or view its properties. 

 

 

3. To refer an object to a trigger position, use the object's properties page general tab: 

Note: triggers are applicable to objects of type Signature box,identification,datafield and 

output name identifier.    
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   Extracting and using Data Fields 

 

Data fields can be defined to be extracted for further use during document "printing" 

process.  Data field can be stored at an external file, used for special additional output file 

naming managing which couldn’t be handled by the designer, assist in output archiving and 

indexing and more.  

 

 

1. While in "Create mode", click the "Add data field" button. 
 

  
 

 

2. Locate and mark a box around the string you would like to define as data field by 

left clicking the mouse button while holding it, dragging the corner and releasing 

the button. 
 

3. Name the data field: 

 

 
 

4.   Clicking the "OK" button his will create an orange box marking the data field. 
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Handling output file names 

 
Controlling output file names is an important integration tool while working with organizational systems. 
Signature Wizard enables setting dynamic output file names, using input file data, document data fields, 
prefixes and fixed strings. 
 

1. While in "Create mode", click the "Output file name" button. 
 

  
 
 

2. The following bar will appear under the current one: 

 
 

3. Mark any string combination in input file name and click the "Add" button to add 

the strings to output name. Click "Customize" to open output file name form: 

 

 
 

Use any right side output file naming pattern to build the output name format (Out 

format).  

 

4. Check "Add date / time" checkbox to add time stamp to file name.  
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5. Select delimiter from delimiters list to delimit strings in file name.  

 
 

6. Click "Add pre/suffix" button to add prefix or suffix to output file name: 
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Handling input file names 

 
Input file name data can be used both for alternative to/additional template identification and matching 
and/or data fields extraction from the input file name for further processing and integration. 
 

1. While in "Create mode", click the "Input file name" button. 
 

  
 

Input file name form will open: 

 

 
 
 

2. Mark any string from the input original file name into input file name identification 

pattern by clicking the "Add" Button.  

3. Set any marked string as data field by clicking the "Set as data field" button and 

name it: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Input file name data can be used both for alternative to template identification and matching and/or data 
fields extraction from the input file name for further processing and integration. 
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Prefix-value pair tab 
the prefix value tab allow the user to define a trigger word (hence prefix) that the identification word (hence 
value) comes straight after it or separated only by defined delimiter, the work flow is very similar to “Input 
file name offsets” tab. 
  
 

Assigning before/after session script file 
VPSign client exposes two user exit hooks for external enhancements during processing. These entry 

points can be used to add any pre or post session proceedings for enhancing document handling 

operations during its processing, according to the desired business need and demands. This is achieved 

using the powerful industry standard LUA scripting language, a full function widely used programming 

language that excels with its rich library of free functions and code. 

For further knowledge please visit http://www.lua.org/. 

 
 

1.  Open “Tools” menu then chose “Assign in/out scripts…”. 
 
  
  
  
  
  
  
  
  
  
  
  
  
 

2. Chose the wanted scripts to assign before/after session:  

 

 

Note: the scripts are defined in predefined folder, any new scripts added by the user to that folder will 

           appear automatically at the combo boxes above. 
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Managing templates 

 

Defining working folder 
A working folder need to be defined in order to save/open and export templates from the folder 
, the folder can be redefined and will be used also next time when working with the designer. 
 
Note: a default working folder is defined at setup, if no need to change the working folder the user can skip this section 
and the designer will work with the default working folder named “SwdWorkingFolder”. 
  
To define a working folder: 
 
 

1. Open “Tools” menu then chose “Set working folder …”. 
 

 

 

 

 

 

 

2. Browse to the wanted folder, then click “OK” button: 
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Save Templates 

 

To save new template at working folder: 

1. Open “File” menu then chose “Save As/Save” or alternatively click “Save AS/Save” icon from upper menu 

pane: 

  

  

  

  

  

  

 

 

Or by using upper menu pane “Save” icon on the left or “Save As” icon on the right 

  

2. “Save as” dialog will open at the working folder, then chose a legal windows name and click on 

save button :
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Export Templates 

To export template meaning to export the templates to be used at run time: 

1. Open “Tools” menu then chose “Export templates …”. 
 

  

  

  

  

  

  

  

  

2. The following dialog will appear showing all saved templates at working folder, at default all 

templates are enabled and appear at the list, the user can delete or disable any unwanted 

template, disable using the checkbox on the right column (then the template definition will be at 

the xml used at run time but will be skipped) or the user can  left click on mouse to pick the 

unwanted template (or using Ctrl + left mouse click to multi choice) then click on “X” 

button/press “Delete” at keyboard to remove template(s) from list therefor those templates 

won’t appear at all at the xml used at run time. 
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Remove Templates 

 

To remove templates from the xml used at runtime: 

1. Open “Tools” menu then chose “Remove templates …”. 

 

 

 

 

 
 

 

 

 

 

 

2. The following dialog will open with all already exported templates in the list, use the check box on the left 

column to mark any template to remove then click on “Remove” button. 
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